SOLVED: Making Skype work on Ubuntu


(Ewan Davis) #1

I had Skype v 5.2 for Linux happily working on Ubuntu for since I abandoned MS over 3 years ago. MS have now withdrawn support for 5.2 and it no longer works. There is a new version 10.8.0.4 which should work but I’ve had problems.

I posted the following to the MS forum - No response yet - While I’m very happy never to use Skype again I have to work with those who do - Any ideas?

I have removed old version of Skype from my ubuntu 16.04 and downloaded the deb for the new version from skype.com “-rw-rw-r-- 1 ewan ewan 66964950 Nov 7 16:40 skypeforlinux-64.deb”

When I click on the deb the software centre opens and shows me skypeforlinux 10.8.0.4 ready for install but after I install it shows that I have version 5.2.0.1 installed, which if course shows “Sorry, this version of Skype is not supported anymore” when I run it

I purged the old Skype installation and deleted my .Skype folder from my home directory before installing the deb and the skype icon disappeared from the dash (as it should) but I was left with a mysterious application “ewan.davis Skypetm” -(it’s been there since I first installed Skype) - I don’t seem to be able to do anything to remove this. I suspect it may be the cause of my problem? ewan.davis is my Skype ID.


I tried install with from the command line with dpkg. This also reported it was installing 8.10.0.4 and appeared to succeed but I still getting "“Sorry, this version of Skype is not supported anymore” when I click on the newly installed Skype icon.

Any ideas?

Ewan


(Marcus Baw) #2

Hi @ewan thanks for posting - I didn’t actually know about the new version of Skype for Linux, so I have just installed it (I’m on Linux Mint 18.2). I didn’t have the older version of Skype installed as it happens, so there hasn’t been any issue over version conflicts.

Have you tried stuff like sudo apt remove --purge skype ?

Alternatively, spin up the Synaptic Package Manager and search for packages including the string ‘skype’ - remove everything and then reinstall from the .deb you downloaded from Microsoft’s site.

Marcus


(Ewan Davis) #3

Tried both of those before I posted :frowning:


(Marcus Baw) #4

OK it sounds like somehow the Unity menu entry isn’t getting updated?

Can you remove the ewan.davis Skypetm and Skype entries?

on my machine the Skype binary is at /usr/bin/skypeforlinux and I can launch it from the command line with simply $ skypeforlinux - does this work for you? If so you know that it’s installed on your machine fine, but you need to clean up the launcher entry.

@adrian.wilkins you’re a Unity-ist? how do you fettle entries on the Unity launcher? I use Mint which has a more traditional application menu.

M


(Ewan Davis) #5

I can get rid of the skype entry but not the ewan.davis Skypetm one - I have searched high and low for where this is stored.

typing skypeforlinux works

So does anyone know where the Unity Launcher stores stuff?

Thanks


(Marcus Baw) #6

There’s a thread on OMGubuntu about what sounds like a similar issue

The solution there seemed to be: apt remove skypeforlinux and then move the hidden folder .Skype to .Skypebackup (or delete it)

And then reinstall Skype For Linux


(Ewan Davis) #7

OK sorted used an application called Ezame www.webupd8.org/2013/06/ezame-new-menu-editor-for-unity.html

This allowed me to identify that ewan.davis SkypeTM was coming from a file in my home directory ~/.local/share/applications/skype.desktop removing this solved the problem and the skype ico now opens the new version of skypeforlinux

Thanks


(Marcus Baw) #8

Cool - have taken the liberty of marking the thread as solved and will close


(Marcus Baw) #9